เพิ่มเพื่อน

Userman v.5.xx Mikrotik

 
ก่อนอื่นควรทราบเรื่อง level
สมมุติหอพักคิดว่ามี user active โดยใช้ userman 100 user
ควรใช้ mikrotik ที่เป็น level 6 ครับ
รุ่นต่ำสุดคือ RB1100AHx4 หรือ CCR ขึ้นไปครับ
อีก 2 วิธีที่ทำกันคือ
-ใช้ user จาก winbox สำหรับลูกค้าประจำ และ userman สำหรับลูกค้าขาจรที่ต้องขายบัตร
ตัวอย่าง ลูกค้าประจำ 60 ลูกค้าขาจร 50 รวม active 110
-ใช้ radius นอกซื้ออาจมีค่าใช้จ่ายในการเช่า หรือไม่มี

สมมุติสร้าง 1 user login ได้ 5 เครื่อง แบบนี้จะนับเป็น 5 active ไม่ใช่นับเป็น 1 active ครับ

วิธีที่จะทราบว่ารุ่นนี้ เป็น ROS Level ไหน เข้าเว็บ mikrotik ดูได้
https://mikrotik.com/products/

มันจะบอกรายละเอียดแบบนี้ครับ เช่น 
hEX S

5x Gigabit Ethernet, SFP, Dual Core 880MHz CPU, 256MB RAM, USB, microSD, RouterOS L4, IPsec hardware encryption support and The Dude server package

บทความนี้ผมใช้ RB750 ตัวที่ผมกู้คืนขึ้นมาจากการอัพ ROS แล้วไม่แจก IP 
ROS Version ที่ใช้ผมเป็นตัว 5.21 
*v5 หรือ v6 ตั้งค่าเหมือนกันครับ
 

 
เนตที่ผมใช้มาจาก @TRUEWIFI clone MAC I-phone ลง
หลักการต่อจะเหมือนต่อจาก Airnet หรือ Cable ของ TRUE ใช้ Default Config ไม่ต้องยุ่งยากครับ
 
ข้อสำคัญของ hotspot คือ การอ้างอิงเวลาครับ หากเวลาไม่ตรง พวกเงี่อนไขต่างที่เรากำหนดนอกเหนือจากความเร็ว
มันจะหลุด เช่น เซตให้ใช้ได้ 7 วัน หรือ 30 วัน อาจ log in ไม่ได้ หรือเล่นได้ไม่หมดอายุซักที
 
เซตค่า NTP client หรือตั้งเวลาให้ Mikrotikโดยไปที่ New Terminal copy script ด้านล่างวางแล้ว Enter
**ปัจจุบันใน v6 ntp server ไม่ต้องตั้งก็ได้ ถ้าเช็คเวลาด้านบนแล้วมันตรงครับ
 
/system ntp client set enabled=yes mode=unicast primary-ntp=158.108.212.149 secondary-ntp=202.28.18.72
/system clock set time-zone-name=Asia/Bangkok
 

 
หลังกด Enter แล้ว ถ้า Mikrotik ออกเนตได้อยู่แล้ว วันและเวลาจะตรงครับ
 

 
สร้าง hotspot เป็น file gif นะครับ (ถ้าไม่ติดตรงจับภาพน่าจะไม่เกิน 1 นาที)
 
 
log in จาก user ใน winbox
 
 
 
วิธีการเซต Userman
log in เข้าwinbox ปิด port ที่ไม่จำเป็นออก (ป้องกันการ Hack) เหลือไว้แค่ winbox กับ Userman พอ เวลาจะใช้ port อื่นค่อยมาเปิดเอา
และเปลี่ยน port www จาก 80 เป็น 81 โดยไปที่ IP>>>Service (อันนี้ คือ port เวลาเข้า Userman ครับ)
 
 
สร้าง Radius ใน winbox ตามรูป
Radius กด + ติ๊กถูกตรง hotspot
Address=127.0.0.1
Secret=1 แล้วกด OK (จะเปลี่ยนเป็น 3231 ก็ได้ แต่ต้องตรงกันกับใน userman)
 
 
เปิดใช้งาน Raduis ใน Hotspot
เมนูจะอยู่ใน IP>>>Hotspot แท็บ Server Profiles 
Profile Hotspot ที่เราสร้างขึ้นมา ติ๊กถูกตรง Use RADIUS
 

 
Log in เข้า Userman โดยพิมพ์ IP ของ Mikrotik ตามด้วย :81/userman
ตัวอย่างของผมจะเป็น 192.168.88.1:81/userman
user=admin password=ไม่มี
Browser แนะนำเป็น Chrome หรือ Firefox นะครับ IE ส่วนมากจะเข้าไม่ค่อยได้
 

 
ไปที่ Router กด Add New
 

 
Name ใส่เป็นอะไรไปก็ได้ ตัวอย่างผมใส่เป็น Mikrotik
IP Address=127.0.0.1
Shared secret=1  ให้ตรงกันกับใน winbox
Time zone=+07:00
Log events ผมเลือกเอาแค่ Authorization failre จะเอาทั้งหมดก็ไม่ผิดครับ เสร็จแล้วกด Add
 

 
จะได้หน้าตาแบบนี้ครับ
 
 
Customers เปลี่ยน Time zone ข้างล่างเป็น +07:00
***ตรงนี้สำคัญมาก ถ้าเวลาใน radius ไม่ตรง การตัดวันนี้งานอาจหมดก่อน หรือไม่ตรงตามที่ต้องการ
User แนะนำสร้าง password ด้วยนะครับหลังตั้งค่าเสร็จ
เผื่อจะมีคนอื่นมาจัดการสร้างให้ โดยหน้านี้สามารถกำหนดสิทธิ์ได้ด้วยว่าให้อ่านได้อย่างเดียว หรือเป็นผู้ดูแลระบบ
 
 
 
Profile ที่ Limitations
ผมจะเลือกสร้างเพียง Limitations ก่อนนะครับ จะได้ง่าย
โดยกำหนดไว้ดังนี้ เนต 10/1 แบ่งให้ 2M/128k บล็อคบิท limit download และ youtube ลูกค้าประมาณ 15-20 คน ออนไลน์พร้อมกัน
1 ชั่วโมง เทสฟรี/5 ชั่วโมง 10 บาท/1 วัน 20 บาท /3 วัน 50 บาท/7 วัน 100 บาท /15 วัน 200 บาท/30 วัน 300 บาท (กรณีเป็น 7d 15d หรือ 30d ระบบจะเปลี่ยนเป็น 1w 2w1d หรือ 4w2d ให้เอง)
 
**** ข้อดีของการเซต prefig แบบนี้คือ ดูได้ง่าย
ตัวอย่าง user แจ้งว่ารหัสผม 30 วัน ใช้ได้ 20 วันแล้วเข้าไม่ได้ จะได้ตามดูได้ง่ายกว่า random จริงไหมครับ
 
 
 
Profile กด+ สร้างชื่อ Profile และ Create
 

 
Name:ชื่อของ Profile
Name of users:ใส่หรือไม่ใส่ก็ได้
Validity:จำนวนวันใช้งาน
Start:ให้เริ่มนับเมื่อไหร่ กำหนดเป็น At first logon
Price:อัตราค่าบริการ
Shared User:ถ้าต้องการให้ 1 ID log in ได้หลายเครื่องก็ใส่ครับ
กด Save Profile
 
 
กด Add new limitation
เลือกตาม limit ที่เราต้องการ
 
 
หากต้องการเพิ่ม Profile อื่นก็จัดการเลย แต่แนะนำเอาอันเดียวให้ได้ก่อนครับ
 
ไปที่ User เพื่อสร้าง Account กด Add 
One คือ สร้างทีละหนึ่ง
Batch คือ สร้างคราวล่ะมากๆ
 

ในรูปผมสร้างทีล่ะสิบ
ให้คำนำหน้า User เป็ 30d- ตัวอักษรต่อด้านหลัง 4 ตัว ความยาว Password 4 ตัวอักษร อยู่ใน Profile 30d (300.00)

ติ๊กถูกตรงหน้า Usernameเลือก Vouchers เพื่อดูคูปอง


 
จะได้แบบนี้มาครับผมแนะนำแบบง่ายๆ copy ใส่ word ทำแบบฟอร์มไว้แล้ว Print เลย 
 

 
ทดสอบเอา user จากด้านบนมา log in
 

 
log in ได้ สังเกตุสถานะ หน้า server จะเป็นตัว R หมายถึง log in ใช้งานผ่าน Radius ครับ
 

 
เมื่อดูใน Secsions ครับจะเห็น user ที่ใช้งานอยู่
 

 
เพิ่มเติมอีกนิด สำหรับท่านที่ออกคูปองแล้ว มันไม่หมดอายุตามที่ระบุ
ให้เพิ่ม Radius incomming
 
 
และเพิ่ม CoA support ใน userman ด้วย
 
 
หวังว่าบทความนี้คงพอเป็นไกด์ได้นะครับ 
ผมก็งงอยู่หลายรอบเหมือนกัน ติดขัดปัญหาอะไรก็โทรสอบถามได้ครับสำหรับลูกค้า NeXTGENiT
 
สำหรับวันนี้ สวัสดีครับ