เพิ่มเพื่อน

Mikrotik Send IP TO EMAIL

ถ้าจะ Remote เข้า Mikrotik จะทำยังไง
วิธีนี้เหมาะสำหรับคนที่มีพวก iOS และ android ที่สามารถต่อเนตเข้า gmail ได้นะครับ
หรือจะใช้ PC ก็ตามสะดวก

ที่ Tools>>> email ตั้งค่าการส่งก่อน ไม่งั้นไม่ส่งครับ
 
 
ตั้งค่าตามนี้ครับ สำหรับ GMAIL
 
host  173.194.77.108
port  587
from  จากใครล่ะ
email ของคุณ (Gmail)
pass  ของคุณ
 

 
แบบ PPPoE พอดีผมใช้แบบนี้อยู่ครับ
 

pppoe-out1 มาจากไหน
 
 
สร้าง script ชื่อว่า Send_Email แล้วนำไปวางเลย
 
:global currentIP;

:local newIP [/ip address get [find interface="pppoe-out1"] address];

:if ($newIP != $currentIP) do={
    :put "ip address $currentIP changed to $newIP";
    :set currentIP $newIP;
/tool e-mail send to= xxx@gmail.comsubject="wifi4you_WiFi pppoe-out1$newIP" body=" pppoe-out1= $newIP"  tls=yes
}




1=wan ที่ต้องการเช็ค IP
2=Email GMAIL
3=หัวข้อที่ส่ง Email
4=WAN ที่ส่ง IP (จะเป็นอันเดียวกับข้อ 1)

 
แบบ dhcp Client

สร้าง script ชื่อว่า dhcp-client แล้วนำไปวางเลย

:global currentIP;

/tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
:local newIP [/file get dyndns.checkip.html contents]


:if ($newIP != $currentIP) do={
ut "ip address $currentIP changed to $newIP";
:set currentIP $newIP;
/tool e-mail send to= xxx@gmail.comsubject=wifi4you_WiFi ether1" $newIP" body="ether1= $newIP" tls=yes
 
แก้แค่ 3 จุดครับ

ตั้งไว้ 10 นาที จะตรวจสอบว่า ip ใหม่หรือเก่าถ้าใหม่ก็จะส่ง mail แต่ถ้าได้ ip เดิมก็จะไม่ส่ง
โดย copy วางใน Terminal เลย
 
/system scheduler
add name=Send_Email interval=0000 on-event="/system script run Send_Email\r\n"



อันนี้คือ Scheduler ครับ จะรันสคริปทุกๆ 10 นาที ถ้า IP ไม่เปลี่ยนก็ไม่ต้องส่ง Mail
 

อันนี้คือทดลองทำให้เนตหลุดแล้วมัน ส่ง Email แจ้ง IP ครับ
ตัด /32 ด้านหลังออกด้วยนะครับ พร้อมแล้วก็เอา IP ไปมุดเข้าน้องติ๊กเลย

 
 
ข้อดี คือไม่ต้องเสียตังค์
ที่ร้านใช้ dyndns อยู่ ปีล่ะ 20 เหรียญหรือประมาณ 600 บาท/ปี
ข้อเสีย อาจต้องมาเปิดคอมพิวเตอร์ หรือมือถือเพื่อ log in Gmail ดู IP ครับ
แต่ไม่น่าจะลำบาก ผมเห็นลูกค้าท่านนึงเปิด I-Phone ดูอยู่ ปกติถ้าเนตไม่หลุดบ่อยก็เข้า IP เดิมได้ จนกว่า ISP จะตัดเนตทุก 24 ชม.ครับ
 
เครดิตและที่มา Mikrotikclub